Présentation logiciel GesFacture

Présentation du Logiciel GesFacture
Le logiciel GesFacture est un logiciel simple permettant la gestion efficace de votre société.

Il est l'outil idéal pour tout artisan ou toute petite entreprise.

Il permet la gestion simple
  • des adresses de vos clients, fournisseurs, régies et propriétaires,
  • des articles,
  • des devis,
  • des factures,
  • des bons de travail,
  • des lettres,
  • des bons de livraisons.

    • Ce logiciel se caractérise par sa simplicité d'utilisation.

    En 5 minutes seulement, vous êtes capable de créer vos premiers devis et vos premières factures pour un client.

    Le logiciel GesFacture est le logiciel adapté à votre travail quotidien pour une gestion optimale de votre société.

    Toute installation du logiciel GesFacture créé le répertoire c:\oligen à l'intérieur duquel se trouve l'ensemble des fichiers permettant le fonctionnement du programme mais aussi l'ensemble de vos données personnelles de gestion.

    Ceci vous permet une gestion efficace des sauvegardes régulières et obligatoires dont vous êtes les seuls responsables pour permettre une reprise efficace de votre travail en cas de défaut de votre PC ou serveur sur lequel était installé votre logiciel.

    Un document présentant différentes façons de réalisation de sauvegardes est présent sur notre site internet http://www.geserp.com

    Vous pouvez associer au logiciel GesFacture, le logiciel GesCompta, ce logiciel vous offre toute la simplicité et le professionnalisme nécessaires à la gestion comptable de votre société.


Présentation de la fenêtre Paramétrage

Présentation du paramétrage
Le paramétrage du logiciel est nécessaire afin d'adapter à votre convenance les documents de gestion de votre société (Bons de travail, Devis, Factures, Lettres, Bons de livraison, etc).
Tous les paramètres du logiciel GesFacture sont accessibles à partir du menu Paramètre.

Dans la fenêtre de configuration dans l'onglet "Option de Base", il est nécessaire de configurer a minima
  • Le code de la monnaie de base : CHF pour la Suisse
  • Le texte de la monnaie de base : Francs Suisse pour la Suisse

    • Une configuration par défaut est réalisée lors de la création d'un nouveau répertoire.

    Le programme est aussi fonctionnel pour la France ou pour l'Allemagne.


Onglet configuration impression

Configuration impression
Cet onglet permet la configuration d'un certain nombre de paramètres liés à l'impression des devis, factures, lettres et bons de travail.
La réalisation de quelques tests est nécéssaire pour déterminer la configuration optimale pour votre société.

Ci après une présentation de cet onglet.

Nous vous aidons dans la création des vos entêtes et pieds de pages.

Nous essayons de nommer le plus simplement les options disponibles du logiciel.


Mise en page de vos documents
Le programme GesFacture permet la personnalisation spécifique de chacun de vos documents gérés par le logiciel (entête, pied de page, bas de page, etc).
Votre personnalisation de page est mémorisée à l'intérieur du répertoire de votre société et s'applique directement à vos devis, lettres ou factures.
Chaque répertoire lié à une société peut être configuré de manière indépendante.
L'onglet suivant vous permet cette configuration.

La personnalisation de ces fichiers se réalise :
  • soit par le biais de GesFacture : Il faut sélectionner le document à modifier et cliquer sur les boutons correspondants aux différentes zones modifiables.
  • soit en éditant les fichiers RTF dans le dossier associé à votre société.

    • Les personnalisations se font par le biais de fichiers RTF que vous pouvez éditer avec l'accessoire windows WordPad présent dans le menu Démarrer->Programmes->Accessoires.

    Tous ces fichiers sont présents dans chaque dossier créé avec GesFacture.

    Nom fichier Description
    devis_entete.rtf Entête du devis, apparaît en haut de la première page du devis.
    devis_haut.rtf Haut de page du devis.
    devis_fin.rtf Fin du devis, ajouté à la suite du tableau
    devis_bas.rtf Bas de page du devis.
    devis_pied.rtf Pied du devis, apparaît en fin de la dernière page du devis.
    confirmation_cmd_devis.rtf Lettre type de confirmation d'une commande à partir du devis.
    lettre_entete.rtf Entête de la lettre d'accompagnement des devis.
    lettre_corps.rtf Contenu de la lettre d'accompagnement des devis.
    lettre_bas.rtf Bas de la lettre d'accompagnement des devis.
    fact_entete.rtf Entête de facture, apparaît en haut de la première page de la facture.
    fact_haut.rtf Haut de facture.
    fact_bas.rtf Bas de facture.
    fact_pied.rtf Pied de facture, apparaît en fin de la dernière page de la facture.
    rappel_entete.rtf Entête commun à tous les rappels.
    rappel_haut_1.rtf Haut du premier rappel.
    rappel_haut_2.rtf Haut du deuxième rappel.
    rappel_haut_3.rtf Haut du troisième rappel.
    rappel_1.rtf Contenu du premier rappel.
    rappel_2.rtf Contenu du deuxième rappel.
    rappel_3.rtf Contenu du troisième rappel.
    rappel_bas_1.rtf Bas du premier rappel.
    rappel_bas_2.rtf Bas du deuxième rappel.
    rappel_bas_3.rtf Bas du troisième rappel.


Modules de GesFacture

Présentation des modules de GesFacture
Le logiciel GesFacture est constitué des modules fonctionnels suivants :
  • Le module de gestion d'adresses permet la gestion des adresses : une adresse pouvant être un client, un prospect, un fournisseur, une régie ou autre.
  • Le module de gestion des articles permet la création, l'édition et la gestion des "articles" ou "prestations".
  • Le module de gestion des devis permet la création, l'édition et la gestion facile de devis pour un client potentiel.
  • Le module de gestion des factures permet la création, l'édition et la gestion facile des factures pour un client.
  • Le module de gestion des bons de travaux permet la création, l'édition et la gestion facile des bons de travaux liés aux régies immobilières.
  • Il vous permet de mettre sur votre facture l'ensemble des champs nécessaires aux régies immobilières.
  • Le module de gestion des lettres permet la création, l'édition et la gestion facile des lettres.
  • Le modules de gestion du planning de vos collaborateurs.

    • Le programme est réalisé de manière à être le plus simple possible en limitant le nombre de fenêtres qu'il est possible d'ouvrir simultanément.

    De plus la philisophie d'utilisation du logiciel GesFacture est identique dans chaque module du programme.

    Vous n'êtes jamais perdu dans l'utilisation du logiciel, quel que soit la fonctionnalité ou module sur lequel vous travaillez.

    Remarque : Bien que l'ouverture de plusieurs fenêtres simultanément soit prohibée pour une facilitation d'utilisation optimale du logiciel, Il existe néanmoins des possibilités de modification d'adresse et/ou d'article durant l'édition d'un devis ou une facture tout en continuant la réalisation du document en cours.

    N'hésitez pas à nous questionner pour toute question sur le logiciel GesFacture.


Etape pour la création d'un devis, d'une facture ou d'un autre document

Etapes de réalisation d'un document
Le logiciel GesFacture est très simple d'utilisation et vous permet la réalisation d'un devis, d'une facture ou d'un bon de travail en quelques clics.
En premier lieu, la réalisation du paramétrage de votre application est nécessaire.

Un paramétrage par défaut est réalisé lors de la création d'un nouveau mandant.
Néanmoins il vous est nécessaire de configurer l'ensemble des informations liées à votre société.

Fenêtre paramètre avec l'ensemble des fichiers d'entête, de corps, de bas de chaque document possible.
Toutes les configurations de présentation de vos documents (entête, bas de page, etc) sont réalisées par l'intermédiaire de fichiers au format RTF et sont enregistrées à l'intérieur de votre répertoire de travail : normalement lui même situé à l'intérieur du répertoire c:\oligen\
-> Par exemple à l'intérieur d'un répertoire ressemblant à c:\oligen\MaSociete

Pour la création rapide d'un devis ou d'une facture, les étapes suivantes doivent être suivies :
  • Création de l'adresse de votre nouveau client ou prospect si celle-ci n'existe pas déjà dans votre liste d'adresses.
  • Création de l'adresse du propriétaire si celle-ci n'existe pas déjà dans votre liste d'adresses.
  • Création vos articles nécessaires à la réalisation du devis ou de la facture dans votre base de donné. Un article correspond à un service ou produit que vous utilisez souvent dans vos devis et ou factures.
  • Cette étape n'est pas nécessaire lors de la création de vos premiers devis. Néanmoins nous vous conseillons la création d'une telle base afin de vous aider dans la création future de vos devis et factures.
  • Si vous gérez un bon de travail, alors veuillez démarrer par la création de ce bon de travail. Ensuite à l'intérieur de celui-ci vous pouvez créer les devis et factures associés à ce bon.
  • Création du nouveau devis ou de la nouvelle facture.
  • Ajout des articles nécessaires au devis ou à la facture.
  • Votre document (devis ou facture) est prêt à être imprimé et envoyé à votre client.

    • Une impression au format PDF est possible, vous permettant ainsi l'envoi de l'ensemble de vos documents par votre logiciel d'email usuel (Thunderbird ou Outlook).

    Attention veuillez lire la remarque actuelle concernant la limitation de l'utilisation pdf directe.
    En cas de problème d'impression directe, veuillez utiliser le logiciel libre PrimoPdf.
    Voir description : Impression en PDF des documents.


Gestion de l'ensemble des articles

Gestion de l'ensemble de vos articles
La fenêtre suivante "Recherche d'un Article" permet la gestion l'ensemble des articles (produits et / ou service) gérés par votre société.

L'accès à cette fenêtre se réalise soit :
  • soit par appui sur le bouton suivant
  • soit en passant par le menu Recherche -> Article

    • Cette fenêtre permet la gestion de l'ensemble des articles de votre société.

    Plusieurs critères permettent la recherche d'un article parmi l'ensemble des articles gérés par votre société.

    La sélection des articles correspondant aux critères est réalisée automatiquement à chaque modification de critères.

    Les critères de sélection se situent en haut de la page de recherche d'articles.

    Un article peut être associé à une classe, permettant le classement et le tri rapide des articles.
    La définition des classes est libre


Saisie d'un article
Un article correspond à un objet physique ou à un service réalisé ou vendu par votre société.

Si vous vendez usuellement cet article, la création d'une référence de celui-ci dans la base de données Articles est conseillée.

Ensuite la sélection des articles depuis la base de données Articles vers un devis ou une facture est réalisée simplement par sélection à partir de la liste des articles présents dans la base de données.

La fenêtre suivante permet la saisie d'un article à l'intérieur de la base de données

Comme indiqué dans cet exemple, l'article dans ce cas correspond à une prestation de service à réaliser.

La société réalisant usuellement cette prestation, il est préférable de l'intégrer dans la base d'article afin de pouvoir intégrer rapidement cet article dans les différents devis ou factures réalisés par votre société.

Remarque : Tout contenu d'un article ajouté à un devis ou une facture ou à un bon de livraison peut être ensuite librement modifié à l'intérieur de ce devis ou de cette facture.
La création d'articles dit "génériques" est par conséquent possible.


Gestion de l'ensemble des devis

Gestion de l'ensemble de vos devis
La fenêtre suivante "Recherche d'un devis" permet la gestion l'ensemble des devis créés pour votre société.

Cette fenêtre permet la gestion complète des devis de votre société.

L'accès à cette fenêtre se réalise soit :
  • soit par appui sur le bouton suivant
  • soit en passant par le menu Recherche ->Devis

    • Cette fenêtre permet le tri des devis selon différents critères

    La sélection des devis est réalisée automatiquement à chaque modification de critères.

    Les trois calculs automatiques suivants sont disponibles :
  • La somme
  • La moyenne
  • Le nombre d'éléments


Saisie d'un devis

Réalisation d'un devis
La réalisation d'un devis est simple et est réalisée grâce à la fenêtre suivante.

L'adresse du destinataire du devis doit être créée avant la création d'un devis.

Champ Description
Devis N° : Numéro de devis (lors de la création du devis, ce numéro s'incrémente automatiquement).
Date devis : Date du devis.
Devise Devise utilisée pour ce devis (si la devise est différente de la devise des articles, une conversion est effectuée automatiquement).
TVA : Taux de TVA (selon le taux de TVA choisi les totaux du devis sont recalculés).
Client Numéro : Numéro du client pour lequel le devis est destiné (les champs «Nom» et «A l'attention de» sont mis à jour automatiquement).

A l'attention de Nom du contact chez le client (défini à l'intérieur de l'adresse de l'entreprise dans l'onglet contact)
Objet L'objet ou le titre du devis.


Etat d'un devis
Pour améliorer la gestion des devis, ils sont caractérisés par un état.

La liste suivante d'état est disponible
  • En cours :Le devis a été créé, enregistré mais pas encore envoyé (apparaît en gris dans la fenêtre de recherche des devis).
  • Envoyé : Le devis a été envoyé mais n'a pas encore été approuvé par le client final. Un devis passe dans cet état lors de son impression. En effet, Gesfacture demande à l'utilisateur une confirmation de l'impression du devis. Si celle-ci est affirmative, l'état du devis passe à l'état « envoyé ».
  • Accepté : Le client final a Accepté le devis qui peut dès lors être converti en facture. C'est seulement à partir de cet état que l'on pourra créer la facture correspondante.
  • Refusé : Le client final n'a pas accepté le devis.
  • Dépassé : Il n'y a pas eu de réponse de la part du client pendant le délai de validité du devis.

    • GesFacture gère automatiquement la majorité des états du devis.
    Cependant l'utilisateur a la possibilité de modifier ces états via la fenêtre de recherche des devis.

    Il est a noter quelques règles pour la modification manuelle des états du devis :
  • l'utilisateur ne peut pas changer l'état du devis qui est En cours.
  • l'utilisateur ne peut pas remettre l'état du devis à En cours si l'état actuel du devis est différent de l'état En cours.

    • Une fois que le devis a été approuvé, une facture et ou une lettre spécifique, peuvent être créées et associées à un devis.


Gestion de l'ensemble des factures

Gestion de l'ensemble de vos factures
La fenêtre suivante "Recherche d'une facture" permet la gestion l'ensemble des factures créées pour votre société.

L'accès à cette fenêtre se réalise soit :
  • soit par appui sur le bouton suivant
  • soit en passant par le menu Recherche ->Facture

    • Cette fenêtre permet la gestion de l'ensemble des factures réalisées par votre société.

    Cette fenêtre permet le tri des factures selon différents critères.

    La sélection des factures est réalisée automatiquement à chaque modification de critères.

    En bas de la fenêtre vous constatez la présence de calculs automatiques.
    La configuration des calculs automatiques disponibles est réalisée par un clic droit sur une colonne possédant des chiffres.

    L'exemple ci après montre la réalisation de la configuration des calculs automatiques

    Trois calculs automatiques sont disponibles :
  • La somme
  • La moyenne
  • Le nombre d'éléments


Saisie d'une facture
La réalisation d'une facture est simple et est réalisée grâce à la fenêtre suivante

Champs Description
Facture N° : Numéro de la facture(lors de la création de la facture , ce numéro s'incrémente automatiquement).
Date Facture: Date de la Facture.
Devise Devise utilisée pour cette facture(si la devise est différente de la devise des articles, une conversion est effectuée automatiquement).
TVA : Taux de TVA (selon le taux de TVA choisi les totaux de la facture sont recalculés).
Client Numéro: Numéro du client pour lequel le devis est destiné (les champs «Nom» et «A l'attention de» sont mis à jour automatiquement).

A l'attention de Nom du contact chez le client (défini à l'interieur de l'adresse de l'entreprise dans l'onglet contact)
Adresse2 Numéro Numéro de l'adresse 2 lié au document, par exemple l'adresse du propriétaire si le client est une régie immobilière.
Objet L'objet ou le titre de la facture.


Etat d'une facture
Pour améliorer la gestion des factures, elles sont caractérisées par un état.

La liste suivante d'état est disponible
  • En cours : La facture a été créée, enregistrée mais pas encore envoyée (apparaît en gris dans la fenêtre de recherche des factures) : La facture est en cours d'élaboration.
  • Envoyé : La facture a été envoyée au client
  • Payé : La facture a été payée
  • Contrat de maintenance. La facture ne sera pas payée car elle a été considérée comme faisant partie d'un contrat de maintenance.
  • Comptabilisé :La gestion de la facture a été transférée à GesCompta

    • Le filtrage des factures en fonction de cet état est possible.


Gestion de l'ensemble des bons de travail

Gestion des bons de travail
La fenêtre suivante "Recherche d'un bon de travail" permet la gestion l'ensemble des bons de travaux créés pour votre société.

Cette fenêtre vous permet la gestion des bons de travail reçus des régies immobilières.
Saisissez à l'intérieur d'un bon de travail l'ensemble des documents liés à ce bon, c'est à dire le ou les devis, le ou les factures, le ou les courriers, le ou les bons de livraison.

Une fois le bon de travail défini, alors lors de la création du devis, de la facture, du courrier, du bon de livraison, l'adresse de votre client, l'objet des travaux ainsi que le nom du propriétaire sont automatiquement définis.

Cette fenêtre permet la gestion complète des bons de travaux de votre société.

L'accès à cette fenêtre se réalise soit :
  • soit par appui sur le bouton suivant
  • soit en passant par le menu Recherche ->Bon de Travail

    • Cette fenêtre permet la gestion de l'ensemble des bons de travail réalisés par votre société.

    Un ensemble de filtres vous permet une gestion efficace des bons de travaux de votre société.


Saisie d'un bon de travail
Un Bon de travail permet le regourpement de l'ensemble des documents concernant un bon de travail d'une régie immobilère de menière intéligente au sein du programme GesFacture.
Cette fonction optimise grandement la gestion de votre société.

La fenêtre suivante permet la saisie des informations lié à un bon de travail.

A l'intérieur de cette fenêtre vous saisissez l'ensemble des informations reçues de la régie immobilière.
Ces informations sont automatiquement reprises systématiquement dans l'ensemble des documents que vous réalisez concernant ce bon de travail (devis, facture, lettre, bon de livraison)

Vous obtenez une gestion claire de votre bon de travail par l'utilisation de cette fonctionnalité.

L'impression du bon depuis cette fenêtre vous permet de donner à votre collaborateur l'ensemble des informations nécessaires à l'estimation des travaux à réaliser.

Ensuite, en fonction des devis réalisés pour ce bon de travail, il vous est possible d'imprimer le bon correspondant à chaque devis (à partir de l'affichage des différents devis).


Gestion de l'ensemble des Lettres

Gestion de l'ensemble des lettres / courriers
La fenêtre suivante "Recherche d'une lettre" permet la gestion l'ensemble des lettres/courriers créés par votre société.

Un ensemble de filtres vous permet la gestion et la recherche efficaces des lettres de votre société.


Impression avec PrimoPdf
Jusqu'à la version actuelle de Windev, l'environnement Windev ne permet pas une impression correcte des entêtes au format RTF avec tableau et / ou graphique.
Par conséquent, l'impression en pdf des documents intégrant un tableau ou une image dans les fichiers RTF doit être réalisée avec une autre imprimante Pdf.

Nous conseillons à nos clients l'utilisation de l'imprimante PrimoPdf (version gratuite : voir http://www.primopdf.com/).
Nous rappelons que PrimoPdf est un logiciel libre que vous devez installer sur votre ordinateur afin d'ajouter l'imprimante pdf liée à ce logiciel.

Une fois l'imprimante PrimoPdf installée l'impression du fichier PDF s'effectue de la manière suivante.

Premièrement, l'impression d'un document s'effectue toujours par l'appui simple sur le bouton "Aperçu avant impression" suivant

Une fois la fenêtre d'aperçu ouverte, vous avez en haut de celle ci les options suivantes:

Vous apercevez dans cette fenêtre les boutons pdf [image] et [image], qui utilisent directement les fonctions windev pour la réalisation de l'impression.

Dans le cas de l'impression sur l'imprimante PrimoPdf, ce ne sont pas ces boutons qui doivent être utilisés mais le bouton impression sur imprimante situé en haut à gauche suivant [image].

Lors de l'appui sur ce bouton, la fenêtre suivante s'ouvre :

A l'intérieur de la liste déroulante, vous pouvez sélectionner l'imprimante PrimoPDF.

Veuillez sélectionner cette imprimante.

Suite à la sélection de cette imprimante, la fenêtre suivante s'ouvre

Maintenant, veuillez cliquer sur le bouton Create PDF

Une fenêtre s'ouvre et la saisie du nom du fichier PDF que vous désirez créer est possible.
Pensez à saisir un nom "parlant" qui vous permettra facilement de retrouver votre document.

Nous vous conseillons au préalable la création d'un répertoire nommé "Primopdf" à l'intérieur de votre répertoire "Mes Documents" à l'intérieur duquel l'ensemble de vos fichiers PDF sera sauvegardé.


Impression directe avec le logiciel
Depuis la version de windev 17 (révision 069m, d'avril 2012), Windev permet l'impression directe du document dans un fichier Pdf, mais cette impression est malheureusement loin d'être parfaite.
Nous vous déconseillons actuellement l'impression "directe".

Actuellement la configuration dans ce mode change un peu l'apercu avant impression raison pour laquelle, une option est rajouté dans la liste des options du programme.

Voir Fenêtre Paramètre de l'application, onglet "Configuration Impression"

Maintenant il est possible d'imprimer directement un fichier Pdf à parti d'un document géré par le logiciel (devis, facture, ou autre)

Pour cela cliquez sur le bouton pdf [image] situé dans l'entête de la fenêtre apercu avant impression.

Lors de l'appui sur ce bouton, la fenêtre vous demandant la saisie du nom du fichier pdf à créer vous est demandé.

Rentrez le nom désiré et vérifier bien le chemin du répertoire dans lequel le fichier va être créé.

Vous pouvez ensuite vérifier le contenu du fichier pdf et le joindre à vos emails avec votre logiciel de mail que vous utilisez usuellement ( Outlook, Thunderbird ).

En fonction de la configuration de votre Ordinateur, l'appui sur le bouton [image] devrait réaliser les deux actions précédentes de manière automatique.

Par contre le choix du fichier pdf à lié à votre email ne vous est pas proposé, raison pour laquelle nous vous conseillons l'utilisation de la méthode séparée, vous permettant ainsi le choix et la gestion des noms des fichiers Pdf.


Présentation

Présentation fonction PostFinance
Le logiciel GesFacture est adapté à l'interface PostFinance définie par La Poste suisse.

Cette fonctionnalité permet la dématérialisation totale des factures auprès d'un de vos clients. La facture est envoyée à votre client au travers de l'interface PostFinance.

Pour cela vous devez posséder un compte PostFinance (EBill Account).

Pour être précis, cette fonctionalité permet l'envoi des factures à vos clients ayant aussi un compte PostFinance directement au travers d'internet au format pdf.

Cette impression est réalisée avec l'imprimante pdf de Windev et par conséquent peut être un peu modifiée par rapport à l'impression directe sur votre imprimante habituelle Windows.

Malheureusement cette différence d'impression est hors de notre champ de développement et il nous est impossible d'améliorer à ce jour la situation. (Il s'agit d'un problème PcSoft déjà sgnalé et toujours pas corrigé de leur part ).

La fonction est réalisée de la manière la plus simple possible pour les utilisateurs de GesFacture.


Configuration PostFinance

PostFinance / Configuration
La configuration des informations nécessaires pour l'utilisation de PostFinance s'effectue principalement à l'intérieur des informations liées à une adresse et donc à l'intérieur de la fiche Adresse.


Configuration adresse société

PostFinance/Configuration/Adresse société
Pour utiliser PostFinance, il faut, avant toute chose, configurer l'adresse de la société, c'est à dire votre adresse de société.

Prérequis :

Pour cette adresse, il faudra avoir à disposition un jeu de données bancaires valides.

Les données de compte nécessaires sont :

Un numéro de compte bancaire IBAN (type CHkk BBBB BCCC CCCC CCCC C pour un IBAN suisse)

et/ou

Un numéro d'adhérent PostFinance.
Ce numéro respecte le masque suivant : 99-999999-9 (9 chiffres).

Pour la partie accès PostFinance, vous avez également besoin de données d'accès. Ces données sont les suivantes :
  • un numéro d'identification, le BillerID, fourni par PostFinance.
    • Ce numéro respecte le masque suivant : 99999999999999999 (17 chiffres).
  • un login
  • un mot de passe
    • Seul le BillerID est nécessaire dans ce chapitre si vous voulez configurer la partie PostFinance de l'adresse de société.
    Les identifiants d'accès login / mot de passe, seront nécessaires pour le paramétrage de l'adresse liée à PostFinance (cf. chapitre "Paramétrage adresse liée à PostFinance").

    Procédure :

    Ajouter votre adresse de société dans la base adresses.

    Il faut tout d'abord lancer le logiciel et sélectionner votre dossier de gestion courant.

    Ouvrir la fenêtre « Recherche d'adresses», soit en cliquant sur le bouton "Recherche d'une adresse" [image] situé sous le menu, soit en passant par le menu 'Recherche/Adresse ...'.

    La fenêtre "Recherche d'adresses" s'affiche.

    Ajouter votre adresse de société si ce n'est pas déjà fait en cliquant sur le bouton "Nouvelle adresse"

    La fenêtre saisie des adresses s'ouvre.

    Tapez le nom de votre société (exemple 'MA SOCIETE') dans les champs "Entreprise" (Onglet "Général") et "Nom de Recherche" en haut de la fenêtre.

    Sélectionner aussi une langue.
    Cela est nécessaire pour l'utilisation de l'interface PostFinance.

    Enregistrer cette nouvelle adresse en cliquant sur le bouton "Enregistrer" en bas à gauche de la fenêtre. .

    Saisissez ensuite les coordonnées bancaires de votre société.
    Cliquer sur l'onglet "Banque" , puis sur le bouton "Ajouter une ligne" [image] .

    La fenêtre "Création / modification d'un compte bancaire" s'ouvre.

    Saisissez un numéro d'adhérent et/ou un numéro d'IBAN valides.
    Cocher « estIBAN » si votre société utilise l'IBAN.

    Cliquer sur le bouton "Fermer" en bas à gauche [image] .

  • A ce stade, vous pouvez également, configurer votre accès PostFinance:
    • Cliquer sur l'onglet "PostFinance".

    Saisissez le numéro BillerID fournit par PostFinance dans le champ "EBill ID".

    Ce numéro respecte le masque suivant : 99999999999999999 (17 chiffres).

    Appuyer sur le bouton "Enregistrer" [image] puis sur "Fermer" [image].


Paramétrage adresse liée à PostFinance

PostFinance/Paramétrage/adresse PostFinance
Prérequis :

Vous avez besoin des vos données d'accès à PostFinance.
Ces données sont les suivantes :
  • un numéro d'identification, le BillerID, fourni par PostFinance.
    • Ce numéro respecte le masque suivant : 99999999999999999 (17 chiffres).
  • un login
  • un mot de passe
    • Le BillerID n'est pas nécessaire si vous l'avez déjà saisi dans l'adresse de société.

    Procédure :

    Choisir l'adresse utilisée pour PostFinance

    Dans le menu, cliquer sur "Paramètres/Paramétrage de l'application"

    La fenêtre "Paramétrage de l'application" s'ouvre.

    Sélectionner l'onglet "PostFinance".
    La page "PostFinance" s'affiche.

    Cliquer sur le bouton "Sélectionner une adresse ..." [image] .

    La fenêtre "Recherche d'adresses" s'ouvre.

    Choisir l'adresse de votre société (exemple 'MA SOCIETE' ) en double-cliquant sur la ligne correspondante.
    La fenêtre "Recherche d'adresses" se ferme.
    Dans la fenêtre "Paramétrage de l'application", dans la page "PostFinance", le numéro et le nom de la société sélectionnée s'affichent dans les champs de texte correspondants.
    Les combos IBAN et ESR se remplissent avec la liste des comptes que l'on a créés précédemment (cf. chapitre "Configuration adresse société").

    Le premier élément de la liste est une chaîne vide, il faut donc dérouler la liste pour voir les comptes créés et sélectionner ceux de notre choix.
    Saisissez les paramètres PostFinance dans les champs appropriés "Nom d'utilisateur" et "Mot de passe".

    Cliquer sur le bouton "Enregistrer" [image] puis sur "Fermer" [image] .
    La fenêtre "Paramétrage de l'application" se ferme.

    Saisir votre identifiant PostFinance (si cela n'a pas été fait lors de la création de l'adresse de société)

    Ouvrir la fenêtre "Recherche d'adresse", soit en cliquant sur le bouton "Recherche d'une adresse" [image], soit en passant par le menu 'Recherche/Adresse ...'.
    La fenêtre "Recherche d'adresses" s'ouvre.
    Choisir l'adresse de votre société (exemple 'MA SOCIETE') en double-cliquant sur la ligne correspondante.
    La fenêtre "Saisie des adresses" s'ouvre.
    Sélectionner l'onglet "PostFinance"
    Vérifier que seul le champ de saisie "EBill ID" est visible.
    La case à cocher "Le client désire recevoir les factures par PostFinance" n'est pas visible pour l'adresse de société.
    Si ce n'est pas le cas, cette adresse n'est pas définie comme étant votre adresse de société.
    Saisissez le numéro BillerID fourni par PostFinance.
    Ce numéro respecte le masque suivant : 99999999999999999 (17 chiffres).
    Appuyer sur le bouton "Enregistrer" [image] puis sur "Fermer" [image].


Configuration client utilisateur de PostFinance

PostFinance/Configuration client
Prérequis :

Vous avez besoin de cette donnée d'accès client à PostFinance :
  • son numéro d'identification, le EbillAcountID.
    • Ce numéro respecte le masque suivant : 99999999999999999 (17 chiffres).

    Procédure :

    Ouvrir la fenêtre "Recherche d'adresses", soit en cliquant sur le bouton "Recherche d'une adresse" [image] situé sous le menu, soit en passant par le menu 'Recherche/Adresse ...'.

    La fenêtre "Recherche d'adresses" s'ouvre.

    Cliquer sur le bouton "Nouvelle adresse" en bas au milieu de la fenêtre [image].

    Une fenêtre "Saisie des adresses" s'ouvre.

    Tapez le nom de votre client utilisateur de PostFinance (exemple 'MON CLIENT') dans les champs "Entreprise" (Onglet "Général") et "Nom de Recherche" situé en haut de la fenêtre.

    Cliquer sur l'onglet "PostFinance".

    Cocher la case "Le client désire recevoir les factures par PostFinance".

    Saisissez le numéro EbillAcountID fourni par PostFinance dans le champ EBill ID.

    Ce numéro respecte le masque suivant : 99999999999999999 (17 chiffres).

    Appuyer sur le bouton "Enregistrer" [image] puis sur "Fermer" [image].


Envoi d'une facture via PostFinance

PostFinance/Envoi facture
Procédure :

Ouvrir la fenêtre « Liste des factures » à l'aide du bouton « Recherche d'une facture » [image] ou depuis le menu "Recherche/Facture... "

La fenêtre " Liste des factures " s'ouvre.

Cliquer sur une ligne d'une facture dont le client est un client PostFinance.

La fenêtre "Facture" s'ouvre avec les informations de la facture correspondante.

L'image PostFinance à droite de l'onglet "Client/Adresse 2" est visible.
La combo "Etat PF" désignant l'état PostFinance, située à droite de l'image est visible.
Modifier l'état PostFinance de cette facture à l'aide de la combo "Etat PF" et sélectionner 'PostFinance' si besoin.
Enregistrer la facture courante à l'aide du bouton "Enregistrer" [image].

Cliquer sur le bouton "Aperçu avant impression..." [image].

La fenêtre "Transfert de la Facture Vers PostFinance" s'ouvre.

Cliquer sur le bouton "Transférer à PostFinance"

Le message 'Transfert en cours. Veuillez patienter …' apparaît en bas de la fenêtre "Transfert de la Facture Vers PostFinance ". Cet affichage dure quelques secondes. Typiquement environ 6 secondes.

Puis une boîte de dialogue indiquant que le transfert du fichier est terminé apparaît alors que le message en bas de la fenêtre est devenu 'Transfert Terminé.'.

Cliquer sur le bouton " OK " de la boîte de dialogue.

La fenêtre "Transfert de la Facture Vers PostFinance " se ferme.

Dans la combo "Etat PF" désignant l'état PostFinance, située en haut à droite de la fenêtre " Détails Facture ", la sélection passe à 'Envoyée'.

Les fichiers factures suivants ont été créés dans le répertoire de gestion courant situé sous " C:\Oligen\" :
  • BillerID_numFacture.xml
  • BillerID_numFacture .pdf


Récupération protocoles de traitement PostFinance

PostFinance/Récupération protocoles de traitement
Afin de contrôler l'état des dernières factures envoyées via PostFinance, La Poste met à disposition certains fichiers, appelés "protocoles", accessibles via son interface internet.
Le logiciel GesFacture intègre un accès à ces fichiers et le traitement des données qu'ils contiennent pour mettre à jour l'état des factures envoyées.

Les fichiers protocoles sont générés par le système PostFinance le soir à minuit si au moins une facture à été envoyée au système dans la journée.
On peut donc les consulter dès le lendemain de l'émission d'une facture.

Procédure :

  • Sélectionner votre dossier de gestion courant situé par défaut dans "C:\Oligen\".
    • Les boutons sous le menus deviennent actifs.

    Si des factures ont été envoyées via PostFinance, un cadre avec des informations PostFinance est affiché en bas à droite de la fenêtre principale de GesFacture.

    On voit nottamment un bouton "Vérification" [image] qui permet d'ouvrir la fenêtre de traitement des protocoles PostFinance, ainsi que les deux indicateurs de nombre de factures envoyées et en erreur.

    Ces indicateurs sont renseignés à l'affichage avec les informations contenues dans la liste des factures. Les valeurs seront ensuite mises à jour avec les informations contenues dans les protocoles qui seront récupérés.

    Cliquer sur le bouton " Vérification ".

    La fenêtre "Vérification transferts PostFinance" s'ouvre.

    Dans "Type de transferts", sélectionner 'Nouveaux' si besoin. Puis cliquer sur le bouton "Vérification" [image] situé en haut à gauche.

    La durée du transfert dépend du nombre de fichiers protocoles récupérés. Elle peut aller jusqu'à plusieurs dizaines de secondes, voire plus d'une minute. A la fin de ce transfert, le message à droite du bouton "Vérification" devient 'Terminé'.

    Les indicateurs "OK", "NOK", et "TOT", de la fenêtre "Vérification transferts PostFinance" sont renseignés avec les valeurs respectives du nombre de factures envoyées avec succès, celles qui sont en erreur et le nombre total de factures, à savoir la somme des deux premiers nombres.

    Les indicateurs de factures envoyées et en erreur de la fenêtre principale du logiciel, sont également renseignés.

  • Il est également possible de récupérer les informations archivées sur les factures des 40 derniers jours.

    • Pour cela, il faut sélectionner 'Archives' dans "Type de tranferts".
    On peut également spécifier une date dans le champ "Date" qui est visible pour ce type de transferts [image].

    Si aucune date n'est spécifiée, tous les fichiers archivés sont récupérés et traités. Donc tous ceux des 40 derniers jours.

    Si une date est spécifiée, seuls les fichiers ayant une date supérieure ou égale à la date spécifiée sont récupérés et traités.


Présentation

Impression des BVR
Le logiciel GesFacture permet directement l'impression des BVR des factures que vous créez.
Un certain nombre de paramètres permettent la configuration optimale de votre logiciel afin d'imprimer votre bulletin BVR.

Le logiciel est prévu pour définir une imprimante sur laquelle sont réalisés les impréssions des BVR.

Cette définition est réalisée à l'intérieur de l'onglet BVR de l 'ensemble des onglets de la fenêtre BVR.


Configuration BVR

BVR/Configuration
C'est dans l'adresse de la société, au niveau de la configuration des comptes bancaires, que les BVR vont être configurés.

Prérequis :

Vous devez disposer des éléments suivants :

  • un numéro d'adhérent PostFinance

    • Ce numéro respecte le masque suivant : 99-999999-9 (9 chiffres).

  • la police de caractères OCR-B installée sur le poste ou est executé GesFacture.
    • Cette police, fichier "ocr-b-10-bt-5260.ttf", peut être téléchargée depuis le site internet de GesErp à la page suivante :
    http://www.geserp.com/telechargements/mises-a-jour

  • une imprimante

  • un gabarit transparent fourni par PostFinance pour vérifier la position des champs des bulletins de versements imprimés
    • Ci-dessous un exemplaire de Gabarit de position pour formulaires OCR-B Poste

    Procédure :

  • Configuration de la partie 'Compte bancaire' pour l'adresse de société

    • Veuillez vous reporter au chapitre PostFinance/Configuration adresse société, afin de configurer le compte bancaire et le numéro d'adhérent de votre société.

  • Configuration de la partie BVR pour l'adresse de société

    • Depuis la fenêtre "Création / modification d'un compte bancaire", cliquer sur l'onglet "Configuration BVR"